VideoCache

squid -k reconfigure

by sirkike on 5 Feb 2009

When i do squid -k reconfigure, squid reconfigure very well, and videocache.log report: RELOAD videocache plugin was reloaded but videos are don't cache at all, i need restart squid complety to works property.
i uses:
RH ent4
Squid 2.7.STABLE5
and lastest cachevideos 1.8

sorry bad english... :P

7 Answers

by Kulbir Saini on 5 Feb 2009

Sirkike,

Can you please provide these details?
1. Does XMLRPC continue to run after reconfigure?
2. Any tracebacks or errors in squid's cache.log file.

Thank You!

by sirkike on 6 Feb 2009

Cache.log don't report anything

2009/02/05 11:25:29| Reconfiguring Squid Cache (version 2.7.STABLE5)...
2009/02/05 11:25:29| FD 14 Closing HTTP connection
2009/02/05 11:25:29| FD 15 Closing HTTP connection
2009/02/05 11:25:29| Including Configuration File: /etc/squid/squid.conf (depth 0)
2009/02/05 11:25:29| Cache dir '/cache/squid' size remains unchanged at 41697280 KB
2009/02/05 11:25:29| Initialising SSL.
2009/02/05 11:25:29| Store logging disabled
2009/02/05 11:25:29| User-Agent logging is disabled.
2009/02/05 11:25:29| Referer logging is disabled.
2009/02/05 11:25:29| DNS Socket created at 0.0.0.0, port 35123, FD 5
2009/02/05 11:25:29| Adding nameserver 127.0.0.1 from squid.conf
2009/02/05 11:25:29| Adding nameserver 200.45.191.35 from squid.conf
2009/02/05 11:25:29| Adding nameserver 200.45.191.40 from squid.conf
2009/02/05 11:25:29| helperOpenServers: Starting 3 'python2.4' processes
2009/02/05 11:25:30| Accepting transparently proxied HTTP connections at 10.100.100.1, port 3128, FD 41.
2009/02/05 11:25:30| Accepting transparently proxied HTTP connections at 127.0.0.1, port 3128, FD 42.
2009/02/05 11:25:30| WCCP Disabled.
2009/02/05 11:25:30| Loaded Icons.
2009/02/05 11:25:30| Ready to serve requests.

and videocache.log show this:

2009-02-05 11:25:29,748 15811 - - RELOAD - videocache plugin was reloaded.
2009-02-05 11:25:29,748 15812 - - RELOAD - videocache plugin was reloaded.
2009-02-05 11:25:29,749 15813 - - RELOAD - videocache plugin was reloaded.

and sometimes NOT always, videocache.log after all that lines, show this when try to view a youtube video:

2009-02-05 17:54:00,702 26970 - - STRAT_XMLRPC_SERVER_ERR - Cannot start XMLRPC Server - Exiting
by Kulbir Saini on 6 Feb 2009

Sirkike,

How many redirectors are you using? Using too many redirectors cause this problems sometime. Anything between 5-10 should be fine :)

Thank You!

by sirkike on 6 Feb 2009

Only use videoscache, with default config (except the cache dir)

by Kulbir Saini on 6 Feb 2009

Sirkike,

You probably misunderstood my question or I asked the wrong question. I was asking what is the number of rewrite programs you are using. As in what is the value of N in

url_rewrite_children N

Thank You!

by sirkike on 6 Feb 2009

u are right... the value was 10 (at the limit, i suppose), change to 5 now... and works fine!!

Thanks u very much!!!

by Kulbir Saini on 6 Feb 2009

Nice. Congratulations for the setup and enjoy caching videos :D

You need to sign in. Please sign in to add answer to this question.