VideoCache

1.9.4 Youtube still have some problem

by kingliub on 7 Apr 2010

I have request 4 videos on youtube, it seems that videocache didn`t start downloading as soon as the video scheduled for download, but after several minutes or more.

while other sites goes well, I tried metacafe, it starts downloading the moment it scheduled.

Here is one of the four youtube log, the other three are the same except time:

2010-04-07 11:08:39,919 7320 172.16.3.123 lDfknS1V9l0 SCHEDULED YOUTUBE Video scheduled for download.
2010-04-07 11:53:31,334 8259 172.16.3.123 lDfknS1V9l0 ALTERNATE_URL_ERR YOUTUBE StringIO instance has no attribute 'geturl'
2010-04-07 12:04:50,149 8259 172.16.3.123 lDfknS1V9l0 DOWNLOAD YOUTUBE 37752368 Video was downloaded and cached.

From the log you can see it has waitted for near 50 minutes before downloading. There will be lots of videocache processes if the problem don`t be resolved.

Waitting for your response, thank you!

6 Answers

by arios on 8 Apr 2010

are you using proxy in videocache.conf ?

by kingliub on 8 Apr 2010

No, proxy is NULL, other sites go well but youtube, the problem is that it didn`t download youtube video immediately, because i can not see downloading file in '/var/spool/videocache/tmp', but have to wait for a long time. While other sites can see the moment it is scheduled for download!

by arios on 8 Apr 2010

can you give me full error log ? use http://pastebin.com/

i never have "StringIO instance has no attribute 'geturl'" error

by kingliub on 9 Apr 2010

http://pastebin.com/QAB3RexT
This is a youtube full log, '/var/spool/videocache/tmp' don`t have downloading file untill "StringIO instance has no attribute 'geturl'".

Another problem: Why a url request logged twice?
From the log you can see every url have two URL_HIT, CACHE_MISS and NEW_URL.

by arios on 9 Apr 2010

yes i have 2 request also , that log showed your videocache worked fine. it said "was downloaded and cached".

by kingliub on 10 Apr 2010

But the problem is it waitted too long before downloading, so there are too many videocache processes running, it will exhaust my os resource.

You need to sign in. Please sign in to add answer to this question.