VideoCache

Access deny

by toninos on 5 Feb 2010

I ask for help! I have Ubuntu Server 9 with squid 2.7 and Apache2, I have 2 network cards one of which is eth0 connected to internet with dynamic IP address and eth1 with static address 192.168.0.1 (lo) and 127.0.0.1 inet inet6:: 1 / 128, I installed python VideoCach etc. I installed as root using python setup-deb.py and the installation was successful
I put iptables MASQUARADE eth0, then eth1 iptables PREROUTING side (client) destination port 80 to 3128 for the proxy and finally echo 1 situation so the client does not let me access the internet. please help me I'm definitely doing something wrong, but what?
ps I tried to withdraw from squid.conf configuration used to VideoCach and the result is that the client side makes me enter the Internet without caching video I only cache sites. thanks in advance

4 Answers

by toninos on 5 Feb 2010

but it takes a particular routing iptables? 'm about to go crazy

by Kulbir Saini on 6 Feb 2010

Hi!

Can you please check if your squid access internet via itself?

Thank You!

by toninos on 6 Feb 2010

yes, but after installed VideoCach not within the Internet

by toninos on 7 Feb 2010

I solved the proxy server, I can intrare in interntet and YouTube videos dig saved without problem, then see them again without waiting for the mail youtube thinks my proxy, in fact we are in the folder 127.0.0.1/videocache/youtube added files. There is just the problem the client side when I see videos I've seen out that you can not see the video. help me? details eth0 wan (internet eth1 (LAN Client)
iptables eth0 MASQUARADE eth1 dport 80 iptables to redirect port 3128 and finally echo 1. regle maybe these are not good??

You need to sign in. Please sign in to add answer to this question.