VideoCache

ACL name 'videocache_deny_dom' not found.

by Anonymous on 4 Mar 2011

I'm trying to get videocache 1.9.2 working with squid 3.1.8. I'm working on a gentoo box, updated to the latest stable hardened-sources kernel. It looks like I have a couple versions of python, I don't know why.

dev-lang/python-2.6.6-r1 was built with the following:

USE="gdbm ipv6 ncurses readline ssl threads (wide-unicode) xml -berkdb -build -doc -examples -sqlite -tk -wininst"
CFLAGS="-O2 -march=native -pipe -O2 -fomit-frame-pointer -fwrapv"
CXXFLAGS="-O2 -march=native -pipe -O2 -fomit-frame-pointer -fwrapv"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -L."

dev-lang/python-3.1.2-r4 was built with the following:

USE="gdbm ipv6 ncurses readline ssl threads (wide-unicode) xml -build -doc -examples -sqlite -tk -wininst"
CFLAGS="-O2 -march=native -pipe -O2 -fomit-frame-pointer -fwrapv"
CXXFLAGS="-O2 -march=native -pipe -O2 -fomit-frame-pointer -fwrapv"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -L."

Anyhow, regarding the actual problem... everything installed fine, except that when installing videocache, it said that -u was not a valid option, so I installed it without -u and all went well (apparently). Then, I added the right lines into squid.conf, and now when trying to start squid... I get this:

localhost videocache-1.9.7 # /etc/init.d/squid restart
 * Starting squid ...
2011/03/03 15:49:52| aclParseAclList: ACL name 'videocache_deny_dom' not found.
FATAL: Bungled squid.conf line 23:          url_rewrite_access deny  videocache_deny_dom
Squid Cache (Version 3.1.8): Terminated abnormally.
CPU Usage: 0.004 seconds = 0.000 user + 0.004 sys
Maximum Resident Size: 14528 KB
Page faults with physical i/o: 0 

Any help would be appreciated.

1 Answers

by Kulbir Saini on 15 Mar 2011

Hello,

Can you please contact us directly using contact link? Please don't forget to mention the email address using which you purchased videocache.

Thank You!

You need to sign in. Please sign in to add answer to this question.