VideoCache

cachevideos 1.9 and squid 3

by Anonymous on 25 Jun 2009

Dear Cachevideos Devel.,
Firstly i would like to thank you for the great efforts you are doing guys. I really appreciate it deeply and i feel im honored to be one of those that will participate to improve this work.

I have my squid 3 up and running using wccpv2 and it works perfectly. While googling, i came thru cachevideos that lightened my day with the simplicity and giant work this application can help.

However, i followed up all the needed instructions and my setup is installing cachevideos on squid server that is using one interface. Youtube files are cached and i can play them back as i copy then into my HDD. The problem being encountered that during replying the same flash again using the same link on the browser (Just as if i open it again on the browser) videocache log shows hit but i get "error try later again" on my browser.I come cross this on every youtube file being cached.

Please advise on the best approach to tackle this problem

Thanks again for the support in advance

GALALA

11 Answers

by GELL on 25 Jun 2009

In addition, Any configuration need to be added/altered on httpd conf file,].. i didnt make any changes and i have a feeling tt my problem is due to the webserver setting. Plz advise

by GELL on 29 Jun 2009

Hi

ANy update on this matter plz as i have nt got any feedback though there were newer tickets being processd by admin.
thnx

by Kulbir Saini on 29 Jun 2009

Gell,

I am sorry for missing your post. Please proceed with this sequence.

  1. Provide information about your operating system.
  2. Provide information on how you installed videocache (from rpm/source).
  3. Check videocache.log for any errors.
  4. Check cache.log (squid) for any python tracebacks or errors.

Please report back with apt information.

Thank you for using videocache :)

by GELL on 29 Jun 2009

Hi
Thanks for the reply.

1) Provide information about your operating system.
Linux-Centos 5.3

2) Provide information on how you installed videocache (from rpm/source).
Firstly, i insalled rpm package but as i upgraded my squid into latest relase 3STANBLE16 i used script to install it as there are no rpm package for this squid release yet.

3) Check videocache.log for any errors

Everything sounds OK

2009-06-29 12:01:52,129 3920 - - XMLRPCSERVER - Starting XMLRPCServer on port 9100.
2009-06-29 12:01:52,129 3920 - - SCHEDULEDER - Download Scheduler starting.
2009-06-29 12:01:53,514 3930 - - UPDATE_SIZE - Size of all caching directories updated successfully.
2009-06-29 12:02:32,275 3917 - - RELOAD - videocache plugin was reloaded.
2009-06-29 12:02:32,276 3918 - - RELOAD - videocache plugin was reloaded.
2009-06-29 12:02:32,278 3920 - - RELOAD - videocache plugin was reloaded.
2009-06-29 12:02:32,280 3919 - - RELOAD - videocache plugin was reloaded.
2009-06-29 12:02:32,281 3921 - - RELOAD - videocache plugin was reloaded.
2009-06-29 12:02:32,282 3922 - - RELOAD - videocache plugin was reloaded.
2009-06-29 12:02:32,284 3923 - - RELOAD - videocache plugin was reloaded.
2009-06-29 12:09:05,948 3954 - - XMLRPCSERVER - Starting XMLRPCServer on port 9100.
2009-06-29 12:09:05,948 3954 - - SCHEDULEDER - Download Scheduler starting.
2009-06-29 12:09:06,963 3966 - - UPDATE_SIZE - Size of all caching directories updated successfully.
2009-06-29 12:09:13,165 3956 - - RELOAD - videocache plugin was reloaded.
2009-06-29 12:09:13,167 3959 - - RELOAD - videocache plugin was reloaded.
2009-06-29 12:09:13,167 3960 - - RELOAD - videocache plugin was reloaded.
2009-06-29 12:09:13,171 3955 - - RELOAD - videocache plugin was reloaded.
2009-06-29 12:09:13,172 3954 - - RELOAD - videocache plugin was reloaded.
2009-06-29 12:09:13,173 3957 - - RELOAD - videocache plugin was reloaded.
2009-06-29 12:09:13,174 3958 - - RELOAD - videocache plugin was reloaded.
2009-06-29 12:09:25,898 3975 - - XMLRPCSERVER - Starting XMLRPCServer on port 9100.
2009-06-29 12:09:25,898 3975 - - SCHEDULEDER - Download Scheduler starting.
2009-06-29 12:09:26,552 3985 - - UPDATE_SIZE - Size of all caching directories updated successfully.
2009-06-29 12:10:28,174 3972 10.0.6.133 - REQUEST - http://v11.lscache4.googlevideo.com/videoplayback?ip=0.0.0.0&sparams=id%2Cexpire%2Cip%2Cipbits%2Citag%2Cburst%2Cfactor&itag=3
4&ipbits=0&signature=D56D30927CA4E4F26BB50E340090481FD3F07C8F.3CBCC2A932C19F4FD27DEB7F3D414B4F7E58C4B5&sver=3&expire=1246273200&key=yt1&factor=1.25&burst=40&id=ad53e538b5c7ef43
2009-06-29 12:10:28,177 3972 10.0.6.133 ad53e538b5c7ef43 URL_HIT YOUTUBE http://v11.lscache4.googlevideo.com/videoplayback?ip=0.0.0.0&sparams=id%2Cexpire%2Cip%2Cipbits%2Citag%2C
burst%2Cfactor&itag=34&ipbits=0&signature=D56D30927CA4E4F26BB50E340090481FD3F07C8F.3CBCC2A932C19F4FD27DEB7F3D414B4F7E58C4B5&sver=3&expire=1246273200&key=yt1&factor=1.25&burst=40
&id=ad53e538b5c7ef43
2009-06-29 12:10:28,177 3972 10.0.6.133 ad53e538b5c7ef43 

4) Check cache.log (squid) for any python tracebacks or errors.

No error being seen

2009/06/29 12:09:23| Successful DNS name lookup tests...
2009/06/29 12:09:23| DNS Socket created at 0.0.0.0, port 34229, FD 8
2009/06/29 12:09:23| Adding nameserver 10.0.3.8 from /etc/resolv.conf
2009/06/29 12:09:23| helperOpenServers: Starting 7/7 'python' processes
2009/06/29 12:09:23| User-Agent logging is disabled.
2009/06/29 12:09:23| Referer logging is disabled.
2009/06/29 12:09:24| Unlinkd pipe opened on FD 20

Kindly verify this for me to ensure ip matching

[root@squid ~]# netstat -ntlp
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name
tcp        0      0 0.0.0.0:706                 0.0.0.0:*                   LISTEN      2220/rpc.statd
tcp        0      0 127.0.0.1:9100              0.0.0.0:*                   LISTEN      3975/(python)
tcp        0      0 0.0.0.0:111                 0.0.0.0:*                   LISTEN      2179/portmap
tcp        0      0 127.0.0.1:631               0.0.0.0:*                   LISTEN      2487/cupsd
tcp        0      0 0.0.0.0:3128                0.0.0.0:*                   LISTEN      3971/(squid)
tcp        0      0 :::80                       :::*                        LISTEN      2518/httpd
tcp        0      0 :::22                       :::*                        LISTEN      2457/sshd
tcp        0      0 :::443                      :::*                        LISTEN      2518/httpd

videocache Conf

cache_host = 127.0.0.1
proxy = http://127.0.0.1:3128/

Looking forward to hearing from you

Regards;

by Kulbir Saini on 29 Jun 2009

GELL,

Your videocache log doesn't say anything like DOWNLOAD, CACHE_HIT etc. See videocache response codes for details.

Everything looks fine. Do you see anything at http://127.0.0.1/videocache/youtube/ or http://127.0.0.1/videocache/0/youtube/ ?

Thank You!

by GELL on 29 Jun 2009

Hi
Sorry i didnt paste that part. Here is the HITs i see on videocache.

2009-06-29 13:50:40,431 3972 10.0.6.133 - REQUEST - http://v11.lscache4.googlevideo.com/videoplayback?ip=0.0.0.0&sparams=id%2Cexpire%2Cip%2Cipbits%2Citag%2Cburst%2Cfactor&itag=34&ipbits=0&signature=54F8AF4FF7E7E00F5AE4DEFB20B25DAE00A4199E.BCC024CCBF6646E8C11A193B16F2C921A39E3C38&sver=3&expire=1246276800&key=yt1&factor=1.25&burst=40&id=ad53e538b5c7ef43
2009-06-29 13:50:40,431 3972 10.0.6.133 ad53e538b5c7ef43 URL_HIT YOUTUBE http://v11.lscache4.googlevideo.com/videoplayback?ip=0.0.0.0&sparams=id%2Cexpire%2Cip%2Cipbits%2Citag%2Cburst%2Cfactor&itag=34&ipbits=0&signature=54F8AF4FF7E7E00F5AE4DEFB20B25DAE00A4199E.BCC024CCBF6646E8C11A193B16F2C921A39E3C38&sver=3&expire=1246276800&key=yt1&factor=1.25&burst=40&id=ad53e538b5c7ef43
2009-06-29 13:50:40,432 3972 10.0.6.133 ad53e538b5c7ef43 CACHE_HIT YOUTUBE Video was served from cache.
2009-06-29 13:50:40,432 3972 10.0.6.133 ad53e538b5c7ef43 NEW_URL YOUTUBE 303:http://127.0.0.1/videocache/youtube/ad53e538b5c7ef43?ip=0.0.0.0&sparams=id%2Cexpire%2Cip%2Cipbits%2Citag%2Cburst%2Cfactor&itag=34&ipbits=0&signature=54F8AF4FF7E7E00F5AE4DEFB20B25DAE00A4199E.BCC024CCBF6646E8C11A193B16F2C921A39E3C38&sver=3&expire=1246276800&key=yt1&factor=1.25&burst=40&id=ad53e538b5c7ef43

Yes the youtube files are downloaded into http://10.20.30.2/videocache/youtube (10.20.30.2 is my proxy ip address)

Thanks
GELL

by Kulbir Saini on 29 Jun 2009

GELL,

Change your cache_host (in videocache.conf) to 10.20.30.2 and then try browsing the video. It should work.

Thank You!

by GELL on 29 Jun 2009

Hi Kulbir;

Correct me if i am mistaken. NEW URL returned to the squid shld be http://10.20.30.2/videocache/youtube instead of http://172.0.0.1/videocache/youtube/?

2009-06-29 14:07:48,688 3972 10.0.6.133 ad53e538b5c7ef43 NEW_URL YOUTUBE 303:http://127.0.0.1/videocache/youtube/ad53e538b5c7ef43?ip=0.0.0.0&sparams=id%2Cexpire%2Cip%2Cipbits%2Citag%2Cburst%2Cfactor&itag=34&ipbits=0&signature=5B5C3CFE6F099DB7BE9FFFE28349238BFFA04003.B133AFC4525329B6A8FC6E1D61FBF0CACBADF27C&sver=3&expire=1246280400&key=yt1&factor=1.25&burst=40&id=ad53e538b5c7ef43
by GELL on 29 Jun 2009

Hi

Sori if im causing you a pain for today but i did change the cache_host but i still see the reutrend URL is 172.0.0.1. I have applied the update-vc as i chaged. Anything else im missing out.

Plz advise

#cache_host = 127.0.0.1
cache_host = 10.20.30.2
2009-06-29 14:29:46,786 3972 10.0.6.133 8931b92baa454165 CACHE_HIT YOUTUBE Video was served from cache.
2009-06-29 14:29:46,787 3972 10.0.6.133 8931b92baa454165 NEW_URL YOUTUBE 303:http://127.0.0.1/videocache/youtube/8931b92baa454165?ip=0.0.0.0&sparams=id%2Cexpire%2Cip%2Cipbits%2Citag%2Cburst%2Cfactor&itag=34&ipbits=0&signature=7BFAF2E4F0728F038CBAE047CA53CC467BC8EA58.58A56FE1A784D5A84237A9F1EFBCDAF0DDEB4D4D&sver=3&expire=1246280400&key=yt1&factor=1.25&burst=40&id=8931b92baa454165
by GELL on 29 Jun 2009

Bingoo Buddy ..it is working now. It was my fault actually as i forgot to restart squid (i just restarted httpd and videocache).

Thanks a lot for all efforts. I will keep you posted on the performance as i might used in somall production environment.

Keep it up buddy

Gell

by Kulbir Saini on 29 Jun 2009

Gell,

Congratulations for the successful setup. I hope it'll help you save some bandwidth :)

Thank you for using videocache :)

You need to sign in. Please sign in to add answer to this question.