VideoCache

can't figure this one out, OSX + CacheVideos error

by Anonymous on 15 Jan 2009

ok i followed the step by step instructions for installing it on my macbook to test how things are running though i had to install DarwinPorts first then the tutorial was easy to follow... i have it loaded i have squid working i even have httpd working..

but when i look at my cache.log i get

Exception in thread Thread-2:
Traceback (most recent call last):
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/threading.py", line 442, in "bootstrap
    self.run()
  File "/usr/share/videocache/videocache.py", line 790, in run
    download_scheduler()
  File "/usr/share/videocache/videocache.py", line 759, in download_scheduler
    if video_id_pool.get_conn_number() < max_parallel_downloads:
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/xmlrpclib.py", line 1096, in "call"
    return self."send(self."name, args)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/xmlrpclib.py", line 1383, in "request
    verbose=self."verbose
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/xmlrpclib.py", line 1129, in request
    self.send_content(h, request_body)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/xmlrpclib.py", line 1243, in send_content
    connection.endheaders()
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/httplib.py", line 798, in endheaders
    self._send_output()
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/httplib.py", line 679, in _send_output
    self.send(msg)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/httplib.py", line 646, in send
    self.connect()
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/httplib.py", line 630, in connect
    raise socket.error, msg
error: (61, 'Connection refused')

for what all the threads for cache.log and all thats in the videocache.log is 10 "scheduleder started"

help :( i really cant wait to test this.

3 Answers

by Kulbir Saini on 19 Jan 2009

Hi Anon,

Please make sure that you have your security setting set so that port 9100 is allowed. If that also doesn't fix your problem, then try restarting squid after killing videocache processes.

Thank you for using videocache :)

by Phantam on 19 Jan 2009

its allowed and other sites are working so far its just youtube

by Kulbir Saini on 19 Jan 2009

Hi Anon,

Can you please cross check your videocache.conf options especially the proxy, cache_host, rpc_host, rpc_port with instructions on configure page.

If the problem still persists, please reply here.

Thank You!

You need to sign in. Please sign in to add answer to this question.