VideoCache

Classic Error Prolly to Misconfig :)

by Anonymous on 29 Jan 2009

Hello all. I'm getting the infamous following in my videocache.log

DOWNLOAD_ERR YOUTUBE An error occured while retrieving the video

The video file name is created in tmp folder with 0 bytes.

I'm using Slackware 12 with the default packages of Apache and Python ( I did install properly the needed modules). I'm also running with no probs squid 2.7 STABLE 5 along squidGuard 1.4.

My current setup uses the zapchain proggy to use both programs.

Any hints would be more than welcome

Cheers,

6 Answers

by Kulbir Saini on 29 Jan 2009

Hi!

Two possibilities,

  1. Your directory permissions are not correct. The /var/spool/videocache and its subdirectories should have 755 permissions and ownership should squid:squid.
  2. Your squid proxy doesn't allow the proxy to use itself as a proxy. I mean add an acl that will allow the proxy to access internet via itself.

Thank You!

by vaylane on 29 Jan 2009

Bizarre.

Both the permissions and ownerships are correct.

I have added in my squid.conf the following but no luck.

acl localvid 127.0.0.1/32 X.X.X.X/26 (where X.X.X.X ofc is the real IP of the proxy)

Is it wrong ? Should the acl be inputed in a different way ?

Thanks again for the quick response

Cheers,

by vaylane on 29 Jan 2009

Edit
(where X.X.X.X ofc is the real IP of the proxy

I ment the real subnet IP's :)

by Kulbir Saini on 29 Jan 2009

Hi Vaylane!

The acl should be like this

acl videocache src x.x.x.x/y
http_access allow videocache

Add these lines and then check!

Thank you for considering videocache!

by vaylane on 29 Jan 2009

@Admin

My poor poor eyes. I had left the rpc_host value to 127.0.0.1. Once I filled in the same IP as cache_host and proxy it all went smoothly!

Thanx for a great piece of software ;)

Cheers,

by Kulbir Saini on 29 Jan 2009

Hi Vaylane,

Never mind :) Hope this will help you cache stuff :)

Thank you for using videocache :)

You need to sign in. Please sign in to add answer to this question.