VideoCache

Doesn't look like Squid3 is invoking the url_rewrite_program

by Arechavaleta on 24 Aug 2009

... but is there a good explanation of how this is supposed to work for those unfamiliar with Python (and coding in general)?

I'm attempting this with a Dell PowerEdge 1950, Ubuntu Jaunty Server with Apache2 installed during installation, squid3, python-iniparse_0.3.1-1_all.deb, and all other requirements installed with "sudo apt-get install".

I'm tailing at least six logs and running tshark on 9100, and I see no activity except in /var/log/squid3/access.log. Here is a snippet from the log during a youtube request:

1251117670.865   2465 10.1.160.118 TCP_MISS/204 293 GET http://video-stats.video.google.com/s? - DIRECT/74.125.87.127 text/html
1251117674.873   6346 10.1.160.118 TCP_MISS/204 293 GET http://s2.youtube.com/s? - DIRECT/74.125.87.127 text/html
1251117675.010    711 10.1.160.118 TCP_MISS/200 266 GET http://api.wipmania.com/74.125.43.138? - DIRECT/91.121.147.207 text/html
1251117679.827  86687 10.1.160.118 TCP_MISS/200 234065 GET http://v15.lscache3.c.youtube.com/videoplayback? - DIRECT/74.125.100.35 video/x-flv
1251117681.918   1806 10.1.160.118 TCP_MISS/302 297 GET http://ad.doubleclick.net/879366/DartShell7_7.swf? - DIRECT/216.73.87.115 -
1251117683.758   3994 10.1.160.118 TCP_MISS/204 468 GET http://www.youtube.com/get_video? - DIRECT/74.125.43.113 text/html
1251117684.380   2460 10.1.160.118 TCP_MISS/200 1007 GET http://172.16.255.200:15871/cgi-bin/blockpage.cgi? - DIRECT/172.16.255.200 image/gif
1251117687.090  17269 10.1.160.118 TCP_MISS/200 25967 GET http://www.youtube.com/watch? - DIRECT/74.125.43.102 text/html
1251117689.057   1801 10.1.160.118 TCP_MISS/302 296 GET http://googleads.g.doubleclick.net/pagead/ads? - DIRECT/74.125.43.154 -
1251117690.561   1499 10.1.160.118 TCP_MISS/200 1007 GET http://172.16.255.200:15871/cgi-bin/blockpage.cgi? - DIRECT/172.16.255.200 image/gif
1251117691.458    881 10.1.160.118 TCP_MISS/302 297 GET http://pagead2.googlesyndication.com/pagead/show_companion_ad.js - DIRECT/74.125.43.167 -
1251117693.043   1582 10.1.160.118 TCP_MISS/200 1007 GET http://172.16.255.200:15871/cgi-bin/blockpage.cgi? - DIRECT/172.16.255.200 image/gif
1251117694.838   1286 10.1.160.118 TCP_MISS/200 4024 GET http://i4.ytimg.com/vi/kh1XkReEjKs/default.jpg - DIRECT/74.125.43.133 image/jpeg
1251117694.913   1352 10.1.160.118 TCP_MISS/200 4089 GET http://i3.ytimg.com/vi/rKUO2oaDBn4/default.jpg - DIRECT/74.125.43.118 image/jpeg
1251117695.008   1446 10.1.160.118 TCP_MISS/200 3945 GET http://i4.ytimg.com/vi/wyV0P8JbljQ/default.jpg - DIRECT/74.125.43.118 image/jpeg
1251117695.033   1468 10.1.160.118 TCP_MISS/200 4092 GET http://i2.ytimg.com/vi/i8CXSxFHSqk/default.jpg - DIRECT/74.125.43.133 image/jpeg
1251117695.068   1526 10.1.160.118 TCP_MISS/200 2529 GET http://i2.ytimg.com/vi/5givmbHSsXw/default.jpg - DIRECT/74.125.43.133 image/jpeg
1251117695.154   1610 10.1.160.118 TCP_MISS/200 3764 GET http://i2.ytimg.com/vi/m8iBJ9R0VMk/default.jpg - DIRECT/74.125.43.118 image/jpeg
1251117695.209   1645 10.1.160.118 TCP_MISS/200 3966 GET http://i4.ytimg.com/vi/wwfr_Ubd-SY/default.jpg - DIRECT/74.125.43.133 image/jpeg
1251117699.529   1140 10.1.160.118 TCP_MISS/204 293 GET http://video-stats.video.google.com/s? - DIRECT/74.125.87.127 text/html
1251117700.202   1784 10.1.160.118 TCP_MISS/204 293 GET http://s2.youtube.com/s? - DIRECT/74.125.87.127 text/html

I believe that everything in my configs is standard except in /usr/sbin/update-vc where "squid_user" and "squid_group" both = "proxy", as using "squid" or "root" appear to consistently crash squid3.

What else would be helpful in diagnosing?

0 Answers

You need to sign in. Please sign in to add answer to this question.