VideoCache

error occurred please try again later’

by cyberia on 12 May 2010

The first time I access a video on youtube it opens normally and it’s being cached on the videocache server.

But if I tried to access it another time I am getting a black screen with the following error ‘error occurred please try again later’

Note that I changed cache_host field to my server IP then update videocache & restart apache + squid but the problem persists.

4 Answers

by Kulbir Saini on 12 May 2010

Hi!

This sounds like a problem with your apache server. Videocache should be accessible via web.

Checklist :

  1. You have SELinux disabled because thats the first thing that prevents apache from working correctly.
  2. Your firewall rules are not preventing access to port 80 on your proxy server.
  3. Apache has at least read access to the specified cache_dir directory on the filesystem.

Thank You!

by arios on 9 Jun 2010

in my case , directory of reading http changed after upgrade to 1.9.5

before was :
/videocache/youtube

after upgrade become :
/videocache/0/youtube

i dont know why , just edit videocache-httpd.conf , the alias from /videocache become /videocache/0

it was solved my problem

by jesquibal on 7 Nov 2010

Hi,

I have the same problem but this time all of my directory settings are correct.

My installation was fresh from the start using v1.9.6-1 RPM.

From the videocache.log I have a CACHE_HIT saying that the video I am trying to view is already in the cache.

2010-11-07 11:30:27,395 13041 192.168.10.10 kv-l7YHbafY CACHE_HIT YOUTUBE Video was served from cache.
2010-11-07 11:30:27,395 13042 192.168.10.10 92ffa5ed81db69f6 CACHE_HIT YOUTUBE Video was served from cache.
2010-11-07 11:30:27,397 13041 192.168.10.10 kv-l7YHbafY NEW_URL YOUTUBE 303:http://127.0.0.1/videocache/youtube/kv-l7YHbafY?fmt=34&el=detailpage&asv=3&t=vjVQa1PpcFMgyMBj4iY8E708wHuo1jTJKT_80CuSy24=&video_id=kv-l7YHbafY&ptk=TheStation
2010-11-07 11:30:28,880 13043 192.168.10.10 kv-l7YHbafY SCHEDULED YOUTUBE Video scheduled for download.
2010-11-07 11:30:32,131 13590 192.168.10.10 kv-l7YHbafY VIDEO_EXISTS YOUTUBE  Video already exists.

Am I missing something here?

TIA

by Kulbir Saini on 12 Nov 2010

Hi!

Your cache_host option is not set correctly in your videocache.conf. Please set it to your private IP or public IP. But don't set it to 127.0.0.1. Then restart Squid.

Thank you!

You need to sign in. Please sign in to add answer to this question.