VideoCache

get_conn_number is not supported

by Anonymous on 18 Jan 2009

I've installed videocache 1.6 on my ubuntu system and got an error:

Exception in thread Thread-2:
Traceback (most recent call last):
  File "/usr/lib/python2.4/threading.py", line 442, in "bootstrap
    self.run()
  File "/usr/share/videocache/videocache.py", line 790, in run
    download_scheduler()
  File "/usr/share/videocache/videocache.py", line 759, in download_scheduler
    if video_id_pool.get_conn_number() < max_parallel_downloads:
  File "/usr/lib/python2.4/xmlrpclib.py", line 1096, in "call"
    return self."send(self."name, args)
  File "/usr/lib/python2.4/xmlrpclib.py", line 1383, in "request
    verbose=self."verbose
  File "/usr/lib/python2.4/xmlrpclib.py", line 1147, in request
    return self._parse_response(h.getfile(), sock)
  File "/usr/lib/python2.4/xmlrpclib.py", line 1286, in _parse_response
    return u.close()
  File "/usr/lib/python2.4/xmlrpclib.py", line 744, in close
    raise Fault(**self._stack[0])
Fault: <Fault 1: '<type \\'exceptions.Exception\\'>:method "get_conn_number" is not supported'>

no matter what am I using, python2.4 or python2.5 error is the same.

squid2.6
iniparse0.2.4

Also i've been using youtube_cache 0.3 and 0.4 while ago, and it was working fine.

2 Answers

by Anonymous on 18 Jan 2009

Oh, sorry, this was just because I forgot to set my IP instead of 127.0.0.1 for RPC host in videocache.conf. Typical case :) read manual word by word. Now it works fine

by Kulbir Saini on 19 Jan 2009

Hi!

Good to know that you fixed it :)

Thank you for using videocache :D

You need to sign in. Please sign in to add answer to this question.