VideoCache

High CPU Usage (95%-100%) on pfsense running Videocache

by Anonymous on 21 Apr 2009

Dear support,

i've just installed videocache on pfsense (latest version for pfsense and videocache).

Its running very well without a problem expect the CPU usage is very high.

Is there any patches or fix for this? I've been searching everywhere and found none.

Thanks

1 Answers

by CacheX on 30 Apr 2009

Guys!

I have a SQUID box installed with videocache support on Debian Lenny and it acts in a router mode to provide transparent cache for my dial users, sometimes it pass hours using all my bandwidth to the internet, as it was downloading some big objects or updating etc…

First, I thought that the clients are requesting much more than their limits or a virus from internal network on clients PC… so I shutdown the entire network and kept SQUID stand-alone running and still the same problem… eating bandwidth …. I restarted the squid and the clients still off and also the same problem… so weird...

After that I used TOP to see what's going on.. and I found like 5 Python process are working and the CPU load for each process almost 20% to 23%..therefore the total CPU usage alsmot 99% ! so I had to kill the processes and shutdown the videocache service and the internet back to normal mode... users are browsing very fast and things now are running smoothly except VIDEOCACHING!!!!

so please any help would be highly appreciated!

Regards,
Cache GURU

You need to sign in. Please sign in to add answer to this question.