VideoCache

How to bring up to date the version?

by Anonymous on 6 Feb 2009

I had installed version 1.6, tried to atulizar for 1.7 and had errors of filing-cabinet, tried to install the 1,8 and I the same gave error, as I decide this? I want to install version 1.8, without losing the recorded videos.

Josué - Brasil

6 Answers

by bellera on 7 Feb 2009

Josué,

I used 1.6, 1.7 and 1.8. Every time I changed I followed these steps:

  • stop squid
  • Move all videocache directories to videocache-1.X
  • Move /etc/videocache.conf to /etc/videocache.conf-1.X
  • Install new videocache version. You will have new videocache directories.
  • Compare /etc/videocache.conf to /etc/videocache.conf-1.X and decide what to do ...
  • Move /var/spool/videocache-1.X files to /var/spool/videocache For migrating to 1.8 you need to move the files without the .flv extension.

Something like will help you:

#!/bin/sh
find /var/spool/videocache-1.X/youtube -name "*" -type f | while read old_video; do
    echo $old_video
    new_video=`echo $old_video | sed -e 's/\\/videocache-1.X\\//\\/videocache\\//g' -e 's/.flv//g'`
    echo $new_video
    mv $old_video $new_video
done

Regards,
Josep Pujadas

by Kulbir Saini on 7 Feb 2009

Thanks Josep for explaining the update process. I'll write a howto on update very soon.

by Anonymous on 7 Feb 2009

Then I go to lose the recorded videos already?

by k1mbl3 on 7 Feb 2009

I've made all the two past updates just installing over the old version, i just had to rename the youtube videos because the .flv extension is gone.

by Anonymous on 24 Feb 2009

I am not obtaining, same moving the names of the directories the same error occurs, somebody can help me?

by Kulbir Saini on 24 Feb 2009

Anon,

Did you follow the upgrade tutorial? If not, follow that. If yes, please post the errors you are getting.

Thank You!

You need to sign in. Please sign in to add answer to this question.