VideoCache

i just install videocache 1.8 but i cant see videos in videocache directory

by Anonymous on 11 Feb 2009

i just install videocache 1.8 but i cant see videos in videocache directory :(

how can i see videos are being cache ..
are there any test script ?

8 Answers

by mahir on 12 Feb 2009

dear admin pls help me :(
this is my videocache.log ..
how can i check videocache run and how can i check videocache dir is there video file or not ..

2009-02-12 00:28:49,215 32058 - - SCHEDULEDER - Download Scheduler starting.
2009-02-12 00:35:15,561 32057 - - RELOAD - videocache plugin was reloaded.
2009-02-12 00:35:15,572 32059 - - RELOAD - videocache plugin was reloaded.
2009-02-12 00:35:15,591 32058 - - RELOAD - videocache plugin was reloaded.
2009-02-12 00:35:15,606 32060 - - RELOAD - videocache plugin was reloaded.
2009-02-12 00:35:15,606 32056 - - RELOAD - videocache plugin was reloaded.
2009-02-12 00:35:17,220 32465 - - XMLRPCSERVER - Starting XMLRPCServer on port 9                                              100.
2009-02-12 00:35:17,221 32465 - - SCHEDULEDER - Download Scheduler starting.
2009-02-12 01:03:00,893 2220 - - STRAT_XMLRPC_SERVER_ERR - Cannot start XMLRPC S                                              erver - Exiting
2009-02-12 01:03:01,437 2222 - - STRAT_XMLRPC_SERVER_ERR - Cannot start XMLRPC S                                              erver - Exiting
2009-02-12 01:03:01,704 2219 - - STRAT_XMLRPC_SERVER_ERR - Cannot start XMLRPC S                                              erver - Exiting
2009-02-12 01:03:02,937 2223 - - STRAT_XMLRPC_SERVER_ERR - Cannot start XMLRPC S                                              erver - Exiting
2009-02-12 01:03:02,953 2221 - - STRAT_XMLRPC_SERVER_ERR - Cannot start XMLRPC S                                              erver - Exiting
2009-02-12 01:23:24,867 5754 - - XMLRPCSERVER - Starting XMLRPCServer on port 91                                              00.
2009-02-12 01:23:24,868 5754 - - SCHEDULEDER - Download Scheduler starting.
2009-02-12 01:47:47,900 5754 - - RELOAD - videocache plugin was reloaded.
2009-02-12 01:47:48,132 5758 - - RELOAD - videocache plugin was reloaded.
2009-02-12 01:47:48,196 5757 - - RELOAD - videocache plugin was reloaded.
2009-02-12 01:47:48,208 5756 - - RELOAD - videocache plugin was reloaded.
2009-02-12 01:47:48,224 5755 - - RELOAD - videocache plugin was reloaded.
2009-02-12 01:47:49,065 7155 - - XMLRPCSERVER - Starting XMLRPCServer on port 91                                              00.
2009-02-12 01:47:49,066 7155 - - SCHEDULEDER - Download Scheduler starting.
2009-02-12 01:48:25,774 7156 - - RELOAD - videocache plugin was reloaded.
2009-02-12 01:48:25,778 7158 - - RELOAD - videocache plugin was reloaded.
2009-02-12 01:48:25,780 7159 - - RELOAD - videocache plugin was reloaded.
2009-02-12 01:48:25,783 7155 - - RELOAD - videocache plugin was reloaded.
2009-02-12 01:48:25,784 7157 - - RELOAD - videocache plugin was reloaded.
2009-02-12 01:48:27,231 7203 - - XMLRPCSERVER - Starting XMLRPCServer on port 91                                              00.
2009-02-12 01:48:27,231 7203 - - SCHEDULEDER - Download Scheduler starting.
by mahir on 12 Feb 2009

i think i found my problem but i dont know ..
how can i fix this ..

2009-02-12 04:36:16,381 20327 127.0.0.1 - REQUEST - http://v3.cache.googlevideo.com/get_video?origin=nyc-v64.nyc.youtube.com&video_id=r3avtOOOZio&ip=88.198.14.155&region=0&signature=A0D4290ADC51A0DC8A77D48C019A42C0B631809F.C5699DA230A6C47DCACCC6F33F7F6B69E688FE7F&sver=2&expire=1234430315&key=yt1&ipbits=0
2009-02-12 04:36:16,388 20327 127.0.0.1 r3avtOOOZio URL_HIT YOUTUBE http://v3.cache.googlevideo.com/get_video?origin=nyc-v64.nyc.youtube.com&video_id=r3avtOOOZio&ip=88.198.14.155&region=0&signature=A0D4290ADC51A0DC8A77D48C019A42C0B631809F.C5699DA230A6C47DCACCC6F33F7F6B69E688FE7F&sver=2&expire=1234430315&key=yt1&ipbits=0
2009-02-12 04:36:16,391 20327 127.0.0.1 r3avtOOOZio CACHE_HIT YOUTUBE Video was served from cache.
2009-02-12 04:36:16,391 20327 127.0.0.1 r3avtOOOZio NEW_URL YOUTUBE 303:http://127.0.0.1/videocache/youtube/r3avtOOOZio?origin=nyc-v64.nyc.youtube.com&video_id=r3avtOOOZio&ip=88.198.14.155&region=0&signature=A0D4290ADC51A0DC8A77D48C019A42C0B631809F.C5699DA230A6C47DCACCC6F33F7F6B69E688FE7F&sver=2&expire=1234430315&key=yt1&ipbits=0
by Kulbir Saini on 12 Feb 2009

Mahir,

You didn't configure your videocache properly. Please do these,

  1. Check if there are videos in /var/spool/videocache/youtube/ ?
  2. Check your cache_host option in /etc/videocache.conf file.

Make sure cache_host option is correct.

Thank You!

by mahir on 12 Feb 2009

thnx for your interest admin ..

yes i can see some videos in videocache director ..

but not playing in flv player .. i think 127.0.0.1 is wrong ..

my squid proxy config on 127.0.0.1
you see here http://127.0.0.1/videocache/youtube/r3avtOOOZio?origin=nyc-v64.nyc.youtube.com& ..

how can i fix this .?
what i should write in videocache config as cache_host ..
:(

2009-02-12 04:36:16,391 20327 127.0.0.1 r3avtOOOZio CACHE_HIT YOUTUBE Video was served from cache.
2009-02-12 04:36:16,391 20327 127.0.0.1 r3avtOOOZio NEW_URL YOUTUBE 303:http://127.0.0.1/videocache/youtube/r3avtOOOZio?origin=nyc-v64.nyc.youtube.com&video_id=r3avtOOOZio&ip=88.198.14.155&region=0&signature=A0D4290ADC51A0DC8A77D48C019A42C0B631809F.C5699DA230A6C47DCACCC6F33F7F6B69E688FE7F&sver=2&expire=1234430315&key=yt1&ipbits=0
by Kulbir Saini on 12 Feb 2009

Mahir,

You should set cache_host to the IP address of your machine.

Thank You!

by mahir on 12 Feb 2009

thnk you very very veryyyy much ..

now its working fine .. :))

videocache now working fine for googlevideo ..

but i live in turkey .
some youtube url has blocked here by ISP ..

if you know is it possible videocache working with proxified youtube url ??

sorry about my english :(

by Kulbir Saini on 12 Feb 2009

Mahir,

I am sorry but videocache doesn't provide any help for proxyfied urls.

Thank You!

by mahir on 12 Feb 2009

thnk you for quick answer and your help

You need to sign in. Please sign in to add answer to this question.