VideoCache

localhost = OK, lan = :(

by Anonymous on 5 Aug 2009

Hello.

10.10.10.1:3128 = squid

Opera running on localhost and "know" about proxy (127.0.0.1:3128) successfully receive videos from VideoCache. I have downloading process in /var/log/videocache and see how fast videos downloading in flash plugins.

But in LAN all users (after installation videocache) cant get videos. They receives html pages, images etc, but not flv files matched by videocache regex in /etc/squid/squid.conf.

Getting URI "http://10.10.10.1:80/videocache/youtybe/123123123123...123123" on LAN machines is OK - file downloading.

Log files
/var/log/squid.conf
/var/log/videocache.conf
are identical after localhost and LAN-machine request on same youtube page.

But /var/log/apache2/access_log contains new records only if i doing localhost's request.

So, if i viewing youtube page from localhost - video loading into flash. If i viewing youtube page from 10.10.10.151 (local machine), video can't load into flash, but VideoCache says (in logfile) that he saw request and served it from cache.

1 Answers

by Kulbir Saini on 8 Aug 2009

Hi Anon,

Make sure your apache is accessible from other machines on your LAN. Also, make sure that your have properly specified proxy and cache_host. They should not be 127.0.0.1, otherwise they will not be accessible from your LAN.

Please paste your logfile /var/log/videocache/videocache.log for more help :)

Thank You!

You need to sign in. Please sign in to add answer to this question.