VideoCache

newurl error in 1.9

by Anonymous on 12 Feb 2009

I try use 1.9 version, but in log speel :

2009-02-12 19:24:14,716 4469 16.16.0.1 8e0a293829c76241 NEW_URL YOUTUBE 303:http://srv1.cachedvideos.com/videocache/0/youtube/8e0a293829c76241?id=8e0a293829c76241&itag=34&ip=201.26.209.49&region=0&signature=56322A146655ED5407A91ED95D92C96B17067228.114918418640DB3321C179D58885A466AE760722&sver=2&expire=1234495454&key=yt1&ipbits=0

in my config file :

cache_host = srv1.cachedvideos.com
base_dir = /cache/www/videocache/

what´s this "/0/" ??? my browser not locate the video because the real dir is :

http://srv1.cachedvideos.com/videocache/youtube

but script send

http://srv1.cachedvideos.com/videocache/0/youtube

anu help???

10 Answers

by Kulbir Saini on 13 Feb 2009

Anon,

Did you follow the upgrade notes properly? Restarted your Apache webserver and squid proxy server after the upgrade/installation ? That url is not an error, it is the new intended behavior to support multiple caching directories.

Please have a look at the upgrade process and let me know if you get any errors with videocache.

Thank You!

by Júlio Henrique de Oliveira on 13 Feb 2009

Kulbir,

I was getting the same erro installing videocache 1.9, then I realized Apache2's error.log was saying "File does not exist: /var/www/videocache/0/youtube". Then I was in /var/cache/videocache and created a directory named 0 and inside him I made a symbolic link with:

ln -s /var/spool/videocache/youtube/ /var/spool/videocache/0/

Now my videocache is working fine.

I'm using Debian Etch.

Congratulations for you work!

Best regards,
Júlio

by Kulbir Saini on 13 Feb 2009

Julio,

That ln command is not needed. I suspect something wrong with your installation. Can you paste your /etc/apache2/conf.d/videocache.conf file somewhere like http://pastebin.com/ ?

PS : Did you change apache_conf_dir variable in setup.py while installing videocache?

Thank You!

by Júlio Henrique de Oliveira on 13 Feb 2009

Kulbir,

I'm using Apache2 and change in setup.py the variable apache_conf_dir for "apache_conf_dir = '/etc/apache2/sites-available/'". Then in this directory is the file videocache.conf.

This is the videocache.conf:

Alias /videocache/0 /var/spool/videocache

<Directory /var/spool/videocache>
  Options +Indexes
  Order Allow,Deny
  #Comment the following line and uncomment the next for public use 
  #Deny from all
  Allow from all
</Directory>

Best Regards,
Júlio

by Kulbir Saini on 14 Feb 2009

Julio,

Then it should have worked without create a 0 directory in /var/spool/videocache/ . It seems your Apache is not treating aliases as it should?

Thank You!

by Júlio Henrique de Oliveira on 14 Feb 2009

Kulbir,

But other aliases it's treating very well. When I install the videocache it will create a directory 0 inside the /var/spool/videocache?

Thank you!

Júlio

by Kulbir Saini on 14 Feb 2009

Julio,

No. When you do a clean installation of videocache, it is not supposed to create a directory '0' in /var/spool/videocache.

Thank You!

by Júlio Henrique de Oliveira on 16 Feb 2009

Kulbir,

I'm writting a HOW-TO install the cachevideo. Then, I'll indicate in text to create the 0 directory. OK?

Thank You!

Júlio

by Kulbir Saini on 16 Feb 2009

Julio,

No. Thats not the standard way. I am not able to understand why its not working. But don't worry, I'll fix it up in next version. You can write that as a tip or hack in the howto marking it with a star or something.

Thank you for your efforts :)

by bellera on 28 Feb 2009

Hello!

Same problem upgrading from 1.8 to 1.9 on FreeBSD. But I think it is my fault because I used a symbolic link to declare to my Apache where the videocache folder is. I didn't modify the Apache configuration.

At previous versions I made:

cd /www
ln -s /var/spool/videocache videocache

(/www it is a symbolic link to my root Apache folder)

For 1.9 I made:

cd /www
unlink videocache
mkddir videocache
cd videocache
ln -s /var/spool/videocache 0

Regards,
Josep Pujadas

You need to sign in. Please sign in to add answer to this question.