VideoCache

no cached videos

by Anonymous on 28 Mar 2009

Hi cachevideos

First of all i like your project and its cool
I use Mikrotik as gateway but i put videocache in front of Mikrotik and now for my network, Videocache is gateway then comes mikrotik

I installed videocache1.8 as described in the installation tutorial everything is fine but i dont see any videos cached in the folders /var/spool/videocache/ how can i be sure that my videocache is working fine and what can be the problem if there is

my /var/log/squid/cache.log

2009/03/28 14:13:54| Initialising SSL.
2009/03/28 14:13:54| logfileOpen: opening log /var/log/squid/access.log
2009/03/28 14:13:54| logfileOpen: opening log /var/log/squid/store.log
2009/03/28 14:13:54| User-Agent logging is disabled.
2009/03/28 14:13:54| Referer logging is disabled.
2009/03/28 14:13:54| DNS Socket created at 0.0.0.0, port 51748, FD 8
2009/03/28 14:13:54| Adding nameserver 10.10.0.100 from /etc/resolv.conf
2009/03/28 14:13:54| helperOpenServers: Starting 5 'python' processes
2009/03/28 14:13:54| Accepting proxy HTTP connections at 0.0.0.0, port 3128, FD 15.
2009/03/28 14:13:54| Accepting ICP messages at 0.0.0.0, port 3130, FD 17.
2009/03/28 14:13:54| HTCP Disabled.
2009/03/28 14:13:54| Accepting SNMP messages on port 3401, FD 18.
2009/03/28 14:13:54| WCCP Disabled.
2009/03/28 14:13:54| Pinger socket opened on FD 19
2009/03/28 14:13:54| Loaded Icons.
2009/03/28 14:13:54| Ready to serve requests.
2009/03/28 14:28:35| logfileOpen: opening log /var/log/squid/netdb.state
2009/03/28 14:28:35| logfileClose: closing log /var/log/squid/netdb.state
2009/03/28 14:28:35| NETDB state saved; 0 entries, 0 msec

This is my /var/log/squid/store.log

1238253399.718 RELEASE -1 FFFFFFFF 97DA2C8A682E69BD6DB9F623582F3FB7  200 1238249799 1238249799 1238253399 application/cache-digest 144/144 GET internal://cache-server.site/squid-internal-periodic/store_digest
1238256999.722 RELEASE -1 FFFFFFFF 27AD7A7DF1B093C79B96643CC141DA24  200 1238253399 1238253399 1238256999 application/cache-digest 144/144 GET internal://cache-server.site/squid-internal-periodic/store_digest
1238260599.726 RELEASE -1 FFFFFFFF 567DDE34E706DB3352B83BCE39B008F0  200 1238256999 1238256999 1238260599 application/cache-digest 144/144 GET internal://cache-server.site/squid-internal-periodic/store_digest
1238264199.730 RELEASE -1 FFFFFFFF BEDC162BEA2135A3778B46372BEE35C4  200 1238260599 1238260599 1238264199 application/cache-digest 144/144 GET internal://cache-server.site/squid-internal-periodic/store_digest

I have put CACHE_HOST 172.16.0.1 and this is my gateway for that network is it OK that way or it requires another configuration

8 Answers

by Kulbir Saini on 28 Mar 2009

Anonymous,

Check your videocache log at /var/log/videocache/videocache.log and see if videocache is working fine. If you are not able to decide, paste the log at http://pastebin.com/ .

Thank you for considering videocache :)

by Anonymous on 28 Mar 2009

Hello Admin.

this is my /var/log/videocache/videocache.log file

http://pastebin.com/m30442468

I see this "SCHEDULEDER - Download Scheduler starting." is it in starting state or it should be in STARTED state..

I hope you will respond because im stuck ..

Thanks

by Anonymous on 28 Mar 2009

with this i mean SCHEDULEDER - Download Scheduler starting.

by Kulbir Saini on 29 Mar 2009

Anon,

You videocache seems to start fine. Did you try browsing some youtube videos after that?

Thank You!

by Anonymous on 29 Mar 2009

Hi admin

I have browsed a lot of videos after that not just youtube from all the webs supported by videocache... but still no files at /var/spool/videocache/youtube or some other folder in this directory

Tell me, in your configuration do you see the video files cached (downloaded) by videocache in the folders /var/spool/videocache/
cuz i cant see even if you say that everything seems to be ok.

by Kulbir Saini on 29 Mar 2009

Anonymous,

I think you are not using the configured proxy properly in your browser. Otherwise there will be a lot of logging activity by videocache. Videos are cached in website specific directories. For example, youtube videos will go in /var/spool/videocache/youtube/ directory.

Thank You!

by invisible on 31 Mar 2009

hi there

What should i configure in my Browser settings for the videocache to start working properly

I have this network 10.10.0.0/24
Mikrotik Gateway 10.10.0.254
Squid Server 10.10.0.15

How should it be
v Autamatic detect settings OR
v Use automatic configuration script >> Address: 10.10.0.15

OR
Proxy Server:
v Address: 10.10.0.15 Port:3128

When i add the Videocache server ip here i get "cannot display the webpage"
Do I have to redirect HTTP requests from my Mikrotik ROS to my Videocache Server
Believe me i have tried a lot of things and :|

KIND REGARDS...

by Kulbir Saini on 31 Mar 2009

Anonymous,

You should have
Proxy Server:
Address: 10.10.0.15 Port:3128

as your proxy settings in firefox.

Also make sure that you have acls to allow access to your machine via squid. Please see if there is anything in videocache log. The videocache log can help me figuring out the problem.

Thank You!

You need to sign in. Please sign in to add answer to this question.