VideoCache

pfsense The url_rewriter helpers are crashing too rapidly....

by schrack-seconet on 2 Feb 2010

Hey, the squid server is crashing when i start it.

Squid Log:
http://nopaste.info/14bbfcb134_nl.html

Permission:
http://nopaste.info/1940fec028_nl.html

videocache config:
http://nopaste.info/efd68fc282_nl.html

Whats wrong?

3 Answers

by Shawn Gadwa on 3 Feb 2010

I used to have the exact same problem! I REALLY need to write a guide on how to install videocache on pfsense. I spent a couple weeks trying to get a working setup. And now, its finally working.

What you need to do is you need to be sure that /usr/local/www/videocache is linked to your videocache directory (/cache/videocache in my case). Then, run ls -l on your videocache directory, /usr/local/www/videocache, and /var/log/videocache.

They all should be owned by proxy:proxy and they all should have read/write privileges.

What I noticed on my setup was that /usr/local/www/videocache was owned by root:wheel even though I did chown -R proxy:proxy on it. The -R command was not working and I needed to force it. So, I did chown -fhv proxy:proxy /usr/local/www/videocache.

My thinking is that since /usr/local/www/videocache is a symbolic link, the -R option is not enough to do it.

I've had a working setup for a while now... on pfsense 1.2.3.

by schrack-seconet on 3 Feb 2010

I have do it... but its not working :/

The same problem.

by belikeyeshua on 5 Feb 2010

If you are using pfsense then you need to set all the directories to proxy:proxy like I said. squid:squid is if you are using linux. Pfsense uses the user proxy and the group proxy. squid:squid won't work.

You need to sign in. Please sign in to add answer to this question.