VideoCache

[Resolved] RPC server cannot reuse port after squid restart

by Anonymous on 13 Dec 2008

Hi,

After you gracefully stop squid, and immediatly start it again (AKA restart :) ), The RPC server cannot reattach to the port.

setting SimpleXMLRPCServer.allow_reuse_address = 1 solves this issue.

8 Answers

by Kulbir Saini on 13 Dec 2008

I think I missed this while coding. Thanks for pointing it out. Will update in the next version.

Thanks for considering videocache :)

by K4c on 23 Jun 2009

I think this option
SimpleXMLRPCServer.allow_reuse_address = 1
and
tcp_tw_reuse = 1

Should be pointed out on first page as necesary for videocache working. Without it is useless software. It was hanging all the time on my system. Will see how it goes now.

tcp_tw_recycle - DON`T set it to 1, it breaks NAT connections !!!

It took me 1 whole day to find the solution. Please post most important information in visible place on your website.

by Kulbir Saini on 27 Jun 2009

K4c,

Thanks for pointing out the necessary instructions here. I didn't post them on configuration page because modifying the tcp_tw_reuse is generally not recommended.

Anyways, it'll be great to know how it is working for you now. Please share.

Thank You!

by Anonymous on 30 Jun 2009

Where do I set this SimpleXMLRPCServer.allow_reuse_address option?

by Kulbir Saini on 1 Jul 2009

Anon,

You need not set this. 1.9.1 has already this set to 1.

Thank You!

by K4c on 15 Jul 2009

Right now i had to stop using videocache, becouse it crashes all the time. Nothing helps, reuse doesn't help and there where some problems with connections tracking when i set it to 1. I turned off videocache and I`m waiting for next version, becouse script is really usefull and safes band.

by moon bhai on 14 Mar 2010

you can set thease both options in videocache.conf file if you want to restart squid or want reload after some changes even it is usefull in the process of log file rotation some oprating system faceing problem of reloding the process of XMLRPCServer witch is related to re bind the port so here you need to add thease lines when you are useing 1.9.2 verion thanks. to K4c

restart videocache server when squid crash or when need to reload. or when you want changes in config. this option need to re bind the port 9100 for XMLRPC Process

SimpleXMLRPCServer.allow_reuse_address = 1

allow reuse of tcp 9100 port when requested restart of proxy.
importent this option not allowed for the users have gateway or nat enabled batter use to restart the server can solve the issue

tcp_tw_reuse = 1

by moon bhai on 14 Mar 2010

look my friend K4c video cache is the effort of a single person not a group its working fine if you install ubuntu 9.10 and configure from start in the port option of appache set 8081 edit files after untar the sorce for support of proxy user its very simple and easy to configure just remove thease lines from squid mention below 2nd batter if you make a script to restart video cache like rc.vccreset

sudo update-vc
sudo service apache2 reload
sudo squid restart 
# for squid 
# hierarchy_stoplist cgi-bin ?
# acl QUERY urlpath_regex cgi-bin \\?
# cache deny QUERY
# check_hostnames off
# half_closed_clients off
quick_abort_min 0 KB
quick_abort_max 0 KB
httpd_suppress_version_string on
server_persistent_connections off
client_persistent_connections off
memory_pools off
buffered_logs on
pipeline_prefetch off
logfile_rotate 10
log_icp_queries off
cache allow localnet

try with this seting its stable.

You need to sign in. Please sign in to add answer to this question.