VideoCache

[Resolved] Transparent Proxy

by Anonymous on 19 Dec 2008

I've installed Videocache (v. 1.6) and it works fine with explicit proxy scenario, but with transparent proxy it doesn't works!!

Here the error after I changed squid.conf from "http_port 8080" to "http_port 8080 transparent" :

  File "/usr/lib/python2.4/httplib.py", line 804, in endheaders
    self._send_output()
  File "/usr/lib/python2.4/httplib.py", line 685, in _send_output
    self.send(msg)
  File "/usr/lib/python2.4/httplib.py", line 652, in send
    self.connect()
  File "/usr/lib/python2.4/httplib.py", line 636, in connect
    raise socket.error, msg
error: (111, 'Connection refused')

Somebody make it work's it transparent proxy scenario?

5 Answers

by Kulbir Saini on 20 Dec 2008

Hi!

Please make sure that your squid acls allow proxy to access Internet via itself. So an acl like

acl this_machine src 127.0.0.0/8
http_access allow this_machine

would normally do.

Also check your /etc/videocache.conf for proxy and cache_host options and make sure they are correct.

Thank you for considering videocache :)

by Anonymous on 24 Dec 2008

Now it works! Thanks!!

I just add on my Squid's ACLs my DMZ network where is my Proxy.

Thank you very much!!

Congratulations to all VideoCache Team!

by Kulbir Saini on 24 Dec 2008

Hi!

I am glad to hear that it finally worked :D

Thanks for using videocache :)

by Anonymous on 25 Dec 2008

Little question...

fine work with transparent proxy using iptables to redirect tcp port 80 to tcp port 8080 (squin in your configuration is working on ths port)
but if I use dns manipulation to obtain a transparent proxy only for some site whithout using iptables (i.e. I can resolve in my network www.youtube.com with the address of the proxy) how can I configure the sistem to work?

apache cannot run on the same (tcp 80) port obviously....

Can I configure the sistem (using more than one address) so that apache and squid can work both on tcp port 80?

or if necessary can I use two different machine?

Many thanks for your help and sorry for my bad english

Have a nice day

by Kulbir Saini on 25 Dec 2008

Hi!

I am sorry but I never worked with systems in such a configuration. Please try in some squid forums or in #squid channel on IRC.

Thank you for using videocache :)

You need to sign in. Please sign in to add answer to this question.