VideoCache

SCHEDULED_ERR - Could not schedule video for download

by Anonymous on 10 Mar 2009

Hi... i'm trying to use videocache but without success... i have installed squid 2.7 STABLE6, an apache server and the lastest version of videocache and the components (iniparse and urlgrabber), the apache and squid configuration has ok, and videocache aparently its ok... squid intercepts the requisition and in the log of videocache shows:

2009-03-10 20:21:28,681 23078 189.77.9.2 - REQUEST - http://v2.cache2.googlevideo.com/videoplayback?id=f597f975eff8f0e9&itag=5&ip=189.77.9.3&signature=6C0C306FCA67F98A2613138A41B1A65AE18E70DD.3229C93BD8533481F574F420BBE95EA5FDFE7C8B&sver=2&expire=1236748885&key=yt1&ipbits=0&redirect_counter=1
2009-03-10 20:21:28,681 23078 189.77.9.2 f597f975eff8f0e9 URL_HIT YOUTUBE http://v2.cache2.googlevideo.com/videoplayback?id=f597f975eff8f0e9&itag=5&ip=189.77.9.3&signature=6C0C306FCA67F98A2613138A41B1A65AE18E70DD.3229C93BD8533481F574F420BBE95EA5FDFE7C8B&sver=2&expire=1236748885&key=yt1&ipbits=0&redirect_counter=1
2009-03-10 20:21:28,681 23078 189.77.9.2 f597f975eff8f0e9 CACHE_MISS YOUTUBE Requested video was not found in cache.
2009-03-10 20:21:28,688 23078 189.77.9.2 f597f975eff8f0e9 NEW_URL YOUTUBE http://v2.cache2.googlevideo.com/videoplayback?id=f597f975eff8f0e9&itag=5&ip=189.77.9.3&signature=6C0C306FCA67F98A2613138A41B1A65AE18E70DD.3229C93BD8533481F574F420BBE95EA5FDFE7C8B&sver=2&expire=1236748885&key=yt1&ipbits=0&redirect_counter=1
2009-03-10 20:21:32,505 23083 189.77.9.2 f597f975eff8f0e9 SCHEDULED YOUTUBE Video scheduled for download.
2009-03-10 20:21:32,511 23083 - - SCHEDULED_ERR - Could not schedule video for download.

the problem is "SCHEDULED_ERR - Could not schedule video for download." , the client assist the video normally, but the is not saved, the owner of the cache directory is squid and the group is squid too... (same config in the squid.conf), i've tried many configuration in videocache.conf but with the same results.... please help me with this problem.... thanks in advance.

PS: My videocache.conf is here:
http://pastebin.com/m5b94f071

Edit: My system is Ubuntu Server 8.10 64bits

18 Answers

by Kulbir Saini on 11 Mar 2009

Anon,

Check if there is something like PARAM_ERR in videocache log. If not then comment line number 463 in /usr/share/videocache/videocache.py and then restart/reload squid.

If the problem still persists, can you please paste your complete videocache log on pastebin?

Thank You!

by Anonymous on 11 Mar 2009

Hi admin, following your orientations i look in the videocache.log, but have nothing speaking about PARAM_ERROR, them i comment the line number 463

(# url = refine_url(url, ['begin', 'start']))

and restarted the squid the results is the same "SCHEDULED_ERR - Could not schedule video for download", i make a new log to resume the situation (after many attempts the log was very big), follow the log of my last attempt in pastebin, i waiting return, thanks.

http://pastebin.com/m5831cd06

PS: The last lines of the log (RELOAD - videocache plugin was reloaded.) are there because i have deactivated videocache in squid, but if i not deactive the lines speaking about the sites (youtube, porntube, etc) following appearing normally, and the scheduleder making these error (SCHEDULED_ERR - Could not schedule video for download), no other error message appear, only this, thanks.

by Kulbir Saini on 11 Mar 2009

Anon,

I can't really figure out what is wrong with your installation. Anyways contact me using contact tab. We'll try to resolve this via email.

Thank You!

by till79 on 11 Mar 2009

Hi,
I´ve got the same problem! My log is complete equal to anon´s entry.
Maybe a version issue?
Suse 11.1-64bit
python 2.6.0-2.21.1-64
python-urlgrabber 3.1.0-178.9
python-iniparse-0.3.1 (from source)

Thank you for videocache!

by Kulbir Saini on 12 Mar 2009

Anonymous, Tillski,

It was a version problem. Please install/reinstall by downloading a fresh version. Sorry for messing things up.

Thank You!

by Anonymous on 12 Mar 2009

GREAT!!!!!!!! It Works!!! And i have integrated with my cache full too... after video cache has dowloaded the video in the next execution of the same video, the speed go to the max with the cache full, its awesome... admin i have now a new doubt... i have a cache hierarchy, i run 2 squids in same machine, the caches are shared and each squid serves one of my networks, exist a way to run 2 videocaches (1 in each squid) for serve the 2 networks?? I waiting your return.

PS: My fiber optic network is watching videos very well now... only lack the network of radios (the other squid)

by Kulbir Saini on 12 Mar 2009

Anonymous,

One videocache installation can be used with two squid. But you have to apply certain hacks for that. Follow these steps.

1- Copy the file /usr/share/videocache/videocache.py to /usr/share/videocache/videocache2.py.
2- Open the file /usr/share/videocache/videocache2.py in any editor change the line #42 to

mainconf =  readMainConfig(readStartupConfig('/etc/videocache2.conf', '/'))

3- Copy the file /etc/videocache.conf to /etc/videocache2.conf.
4- Open the file /etc/videocache.conf in any editor and change the option rpc_port to 9200.
5- Now copy the lines to squid.conf (from installation page). Change the first line to

url_rewrite_program /usr/bin/python /usr/share/videocache/videocache2.py

6- Restart/reload the squid service.

Thank You!

by Anonymous on 12 Mar 2009

Hi admin, worked great.... my 2 squids has now with videocache enabled.... please, add later support for videos from the globo.com portal... thank you for all.

by Kulbir Saini on 12 Mar 2009

Anonymous,

Congratulations for the setup. And thank you for using videocache.

by Wiking on 8 May 2009

Recently I've install new proxy server: Ubuntu 9.04, Squid + Videocache 1.9.1... and I have similar problem "SCHEDULED_ERR - Could not schedule video for download"... but I've other machine with Ubuntu Interpid and Videocache 1.9 and everything is ok... configuration is quite similar. Any suggestions?

by chirvo on 1 Jun 2009

I'm having the same problem here, running Ubuntu 9.04, Squid3 and VideoCache 1.9.1. All dependencies are installed correctly and the directories permissions are set to proxy:proxy (the user:group of squid in Ubuntu).

As a side note, I used the Cherokee webserver instead of Apache, but I don't think this would be the problem.

by Anonymous on 4 Jun 2009

I am having the same problem. I can't post it now because I don't have access, but my videocache.log file imitates the original posters. I am running Ubuntu 9.04 (server edition), Squid 2.7 (I've also tried 3, same problem), Apache 2, and VideoCache 1.9.1. I had problems with the permissions for some files, and that was causing Squid to crash, but I fixed that now. I've enabled http_access on Squid for itself. I've tried everything I can think of really.

The box it's installed is firewalled so that it can only access the internet through another Squid proxy, and I've set it up so that all connections are forced through this proxy on Squid: could this be the cause of the problem?

by Anonymous on 6 Jun 2009

I am having the same problem. I am using CentOS 5.3 with all the required packages installed.

Please let me know how to resolve this issue, as i need this to work in my setup.

by Anonymous on 6 Jun 2009

I have successfuly installed videocache but it is giving me SCHEDULE_ERR. I tried google but it was of no help, for the first time google was unable to provide any help.

Please help me out in resolving this issue so that i can enjoy the use of this marvelous utility.

Looking forward for a quick and helpful reply.

by blake on 19 Jun 2009

THIS POST ASSUMES your problem is the same as described below. If it doesn't work, you've got a different issue.

I was receiving this error on FreeBSD 7.2 with videocache 1.9.1 and Python 2.6.2. I'm assuming its the same issue I had which is videocache is referencing an unknown function, 'splitquery', in the module 'urllib2'. This function is present in the previous version of the module, 'urllib'. I fixed the problem by reverting to using the older module.

I'm not sure which version of Python the videocache developer is using which includes 'urllib2.splitquery'. That would be interesting to know. For now, here's a patch to fix this issue.

--- videocache/videocache.py
+++ videocache/videocache.py
@@ -36,6 +36,7 @@ import sys
 import threading
 import time
 import urlgrabber
+import urllib
 import urllib2
 import urlparse 

@@ -385,7 +386,7 @@ def refine_url(url, arg_drop_list = []):
                 query += arg + '&'
         except:
             continue
-    return (urllib2.splitquery(url)[0] + '?' + query.rstrip('&')).rstrip('?')
+    return (urllib.splitquery(url)[0] + '?' + query.rstrip('&')).rstrip('?')

 def download_from_source(args):
     """This function downloads the file from remote source and caches it."""

Save this patch in a file called urllib2.splitquery.patch in the videocache directory from the tarball. Run patch -p0 < urllib2.splitquery.patch to modify videocache/videocache.py. It should work.

by Omartux on 4 Jul 2009

I have ubuntu intrepid server+ (no apt-get) squid + videocache (setup script)

I had the same problem, and in the post talk about versions and deprecated functions.

I decided to install an earlier version of python (2.5)

apt-get install python2.5

edit squid.conf and i change python env

# --BEGIN-- videocache config for squid
url_rewrite_program /usr/bin/python2.5 /usr/share/videocache/videocache.py
url_rewrite_children 7

i only change /usr/bin/python for /usr/bin/python2.5

now im caching videos weeeeeeeeeee

I hope that you will find it useful

by Anonymous on 23 Mar 2011

i have problem with video cache after i reastart squid i see in the /var/log/squid/cache.log:

Traceback (most recent call last):
  File "/usr/share/videocache/videocache2.py", line 42, in <module>
    mainconf =  readMainConfig(readStartupConfig('/etc/videocache2.conf', '/'))
  File "/usr/share/videocache/config.py", line 695, in readStartupConfig
    confpp_obj = ConfigPreProcessor(configfile)
  File "/usr/share/videocache/parser.py", line 103, in "init"
    fo = self._pushfile( url )
  File "/usr/share/videocache/parser.py", line 197, in _pushfile
    except urlgrabber.grabber.URLGrabError, e:
AttributeError: 'module' object has no attribute 'grabber'

what is the problem please comment thank

by Kulbir Saini on 29 Mar 2011

Hello,

You are using a really old version of videocache. Please upgrade to the latest version 1.9.8.

Thank you!

You need to sign in. Please sign in to add answer to this question.