VideoCache

URL rewrite issues, crashing too fast

by Anonymous on 13 Nov 2009

Has anyone seen this. I have had this working for about 8 months now and after the last reboot this is what I am getting when I start "squid -d 5". Commenting the URL-rewrites out of the squid.conf makes it stop and squid works fine. Python from the command line imports urlgrabber and iniparse just fine. Running /usr/share/videocache/videocache.py from the command line sits there waiting for input.......HELP!!!

# 2009/11/13 13:34:36| Starting Squid Cache version 2.7.STABLE5 for i686-pc-linux-gnu...
2009/11/13 13:34:36| Process ID 7459
2009/11/13 13:34:36| With 1024 file descriptors available
2009/11/13 13:34:36| Using poll for the IO loop
2009/11/13 13:34:36| Performing DNS Tests...
2009/11/13 13:34:36| Successful DNS name lookup tests...
2009/11/13 13:34:36| DNS Socket created at 0.0.0.0, port 45600, FD 5
2009/11/13 13:34:36| Adding nameserver xxx.xxx.xxx.xxxfrom /etc/resolv.conf
2009/11/13 13:34:36| Adding nameserver xxx.xxx.xxx.xxx from /etc/resolv.conf
2009/11/13 13:34:36| helperOpenServers: Starting 15 'python' processes
2009/11/13 13:34:36| User-Agent logging is disabled.
2009/11/13 13:34:36| Referer logging is disabled.
2009/11/13 13:34:36| logfileOpen: opening log /var/log/squid/access.log
2009/11/13 13:34:36| Unlinkd pipe opened on FD 25
2009/11/13 13:34:36| Swap maxSize 8192000 + 8192 KB, estimated 0 objects
2009/11/13 13:34:36| Target number of buckets: 31539
2009/11/13 13:34:36| Using 32768 Store buckets
2009/11/13 13:34:36| Max Mem  size: 8192 KB
2009/11/13 13:34:36| Max Swap size: 8192000 KB
2009/11/13 13:34:36| Local cache digest enabled; rebuild/rewrite every 3600/3600 sec
2009/11/13 13:34:36| logfileOpen: opening log /var/log/squid/store.log
2009/11/13 13:34:36| Rebuilding storage in /var/spool/squid (DIRTY)
2009/11/13 13:34:36| Using Least Load store dir selection
2009/11/13 13:34:36| Set Current Directory to /var/spool/squid
2009/11/13 13:34:36| Loaded Icons.
2009/11/13 13:34:36| Unlinkd pipe opened on FD 30
2009/11/13 13:34:36| Accepting transparently proxied HTTP connections at xxx.xxx.xxx.xxx, port 3128, FD 28.
2009/11/13 13:34:36| Accepting ICP messages at 0.0.0.0, port 3130, FD 29.
2009/11/13 13:34:36| HTCP Disabled.
2009/11/13 13:34:36| WCCP Disabled.
2009/11/13 13:34:36| Ready to serve requests.
2009/11/13 13:34:36| WARNING: url_rewriter #15 (FD 20) exited
2009/11/13 13:34:36| WARNING: url_rewriter #14 (FD 19) exited
2009/11/13 13:34:36| WARNING: url_rewriter #13 (FD 18) exited
2009/11/13 13:34:36| WARNING: url_rewriter #12 (FD 17) exited
2009/11/13 13:34:36| WARNING: url_rewriter #11 (FD 16) exited
2009/11/13 13:34:36| WARNING: url_rewriter #10 (FD 15) exited
2009/11/13 13:34:36| WARNING: url_rewriter #9 (FD 14) exited
2009/11/13 13:34:36| WARNING: url_rewriter #8 (FD 13) exited
2009/11/13 13:34:36| Too few url_rewriter processes are running
FATAL: The url_rewriter helpers are crashing too rapidly, need help!

2 Answers

by Hammerhead on 13 Nov 2009

OK, so here is what I know. Changing the URL rewrite in the squid.conf to reference /usr/bin/python2.4 from /usr/bin/python makes everything work again. I have version 2.6 installed as well as 2.5. 2.4/2.5 work. 2.6 does not.

In the end I had to specify the version of python to get the videocache to start with out "crashing too fast"

Good luck.

by Kulbir Saini on 13 Nov 2009

Hammerhead,

Thank you very much for sharing the solution. Can you please post the exact python version ( output of python command) because I too have python 2.6 on my test system and videocache works fine with it?

Thank You!

You need to sign in. Please sign in to add answer to this question.