Videocache is no longer in development.

video not be cached

by arios on 6 Aug 2011


i tried the fix and it worked for several days. after that it didnt cache anything anymore.

at scheduler.log , it keep say

05/Aug/2011:09:02:56 9023 INFO YOUTUBE CACHE_THREAD_START xkJrIgD0v0E Starting cache thread. -
05/Aug/2011:09:03:02 9023 ERROR YOUTUBE VIDEO_URL_ERR xkJrIgD0v0E Could not determine video URL. -
05/Aug/2011:09:03:02 9023 INFO YOUTUBE CACHE_THREAD_START xkJKP3KQ93c Starting cache thread. -
05/Aug/2011:09:03:05 9023 ERROR YOUTUBE VIDEO_URL_ERR xkJKP3KQ93c Could not determine video URL. -
05/Aug/2011:09:05:09 9023 INFO YOUTUBE CACHE_THREAD_START xk7yCXCdzRg Starting cache thread. -
05/Aug/2011:09:05:12 9023 ERROR YOUTUBE VIDEO_URL_ERR xk7yCXCdzRg Could not determine video URL. -

at trace.log , it keep say

05/Aug/2011:09:00:45 9023 YOUTUBE VIDEO_PAGE_ERR xkfdkVAa-ME
Traceback (most recent call last):
  File "/usr/sbin/vc-scheduler", line 417, in cache_youtube_video
    webpage = urllib2.urlopen(request).read()
  File "/usr/lib64/python2.4/", line 130, in urlopen
    return, data)
  File "/usr/lib64/python2.4/", line 364, in open
    response = meth(req, response)
  File "/usr/lib64/python2.4/", line 471, in http_response
    response = self.parent.error(
  File "/usr/lib64/python2.4/", line 402, in error
    return self._call_chain(*args)
  File "/usr/lib64/python2.4/", line 337, in _call_chain
    result = func(*args)
  File "/usr/lib64/python2.4/", line 480, in http_error_default
    raise HTTPError(req.get_full_url(), code, msg, hdrs, fp)
HTTPError: HTTP Error 404: Not Found

any idea sir ?


1 Answers

by Kulbir Saini on 8 Aug 2011

Hi Kristian,

This is a known issue and has been fixed upstream. Please contact us for latest version.

Thank You!