VideoCache

vidoe cache not running

by Anonymous on 3 Jan 2009

I can not find my configuration error

dedian 4 etch + squid 2.6 stable5 + apache 1.13

/etc/squid/squid.conf
http://pastebin.com/m389f242c

/etc/videocache.conf

enable_video_cache = 1
cache_host = 172.0.0.1
proxy = http://172.0.0.1:5128/

/var/log/videocache/videocache.log
http://pastebin.com/d25a349b7

/var/log/squid/cache.log
http://pastebin.com/d4060b727

7 Answers

by Kulbir Saini on 3 Jan 2009

Hi!

There may be two problems
1. Are you sure you want to set IP as 172.0.0.1 and not 127.0.0.1 ?
2. If yes, you have not added acl for 172.0.0.1 to allow http_access.

Please check these points and get back if it doesn't work yet.

Thank you for considering videocache :)

by Anonymous on 3 Jan 2009

xD thanks

enable_video_cache = 1
cache_host = 127.0.0.1
proxy = http://127.0.0.1:5128/

/var/log/videocache/videocache.log

DOWNLOAD YOUTUBE 4421557 Video was downloaded and cached
CACHE_SERVE YOUTUBE Video was served from cache

firefox www.youtube.com/xxxxxx

We┬┤re sorry, this video is no longer available

:(

by Kulbir Saini on 3 Jan 2009

Hi!

Problem with Apache serving the videos. Try browsing http://127.0.0.1/videocache/ . You should be able to browse it. There should be directories corresponding to websites. And in youtube you'll see some videos. If you get some error, check /var/log/httpd/error_log for proper errors.

Thank you for considering videocache :)

by dank on 4 Jan 2009

hai.. i tried to install & configure videocache
i'm using FC 8, squid-26 S16 and httpd-2.2.9

when installation and configure everything was fine.. nothing error...

at my videocache.conf i'm using base_dir = /cache/videocache/

but when i tried to play video from youtube... there was error "we're sorry, this video no longer available"

i Try browsing http://127.0.0.1/videocache/ and the video file doesn't exist.

but when i check at folder /cache/videocahe/youtube
file is exist....

how to fix it ?

thx....

dank

by Kulbir Saini on 4 Jan 2009

Hi Dank,

Please run the videocache update script as

[root@localhost ~]# update-vc

or

[root@localhost ~]# /usr/sbin/update-vc

Then restart squid server. And try browsing. It should work fine.

Thank you for using videocache :)

by dank on 4 Jan 2009

it's work

thx...

by the way, i have another question.....

what should i do if my hard disk getting full...

thx..

by Kulbir Saini on 4 Jan 2009

Hello Dank,

Congratulations!!

I can't really say anything about the disk space issue right now. But I am looking forward for a autocleanup utility in future versions of videocache.

Thank you for using videocache :)

You need to sign in. Please sign in to add answer to this question.