Videocache is no longer in development.


by Anonymous on 23 Nov 2008
Traceback (most recent call last):
  File "/usr/share/youtube_cache/", line 773, in ?
    log = set_logging()
  File "/usr/share/youtube_cache/", line 146, in set_logging
  File "/usr/lib/python2.4/logging/"init".py", line 1218, in basicConfig
    hdlr = FileHandler(filename, mode)
  File "/usr/lib/python2.4/logging/"init".py", line 757, in "init"
    stream = open(filename, mode)
IOError: [Errno 13] Permission denied: '/var/log/youtube_cache/youtube_cache.log'
[root@proxy ~]# netstat -atpn | grep python

whay mr. admin? how to solve this log?

4 Answers

by Kulbir Saini on 23 Nov 2008

Try this.

[root@localhost ~]# chown -R squid:squid /var/log/youtube_cache/
[root@localhost ~]# chmod -R 755 /var/log/youtube_cache/

After this restart squid service and then check for errors. If you still get any errors get back with details on which version, operating system and how did you install (rpm/tarball)?

by Anonymous on 23 Nov 2008

thanks for replay
my operating system CentOS 5.2 with squid 2.6 and youtube_cache-1.5-1.noarch.rpm
now my log cache

[root@proxy ~]# tail -f /var/log/squid/cache.log
2008/11/24 01:46:42|         0 Objects expired.
2008/11/24 01:46:42|         0 Objects cancelled.
2008/11/24 01:46:42|         0 Duplicate URLs purged.
2008/11/24 01:46:42|         0 Swapfile clashes avoided.
2008/11/24 01:46:42|   Took 0.7 seconds (2975.7 objects/sec).
2008/11/24 01:46:42| Beginning Validation Procedure
2008/11/24 01:46:42|   Completed Validation Procedure
2008/11/24 01:46:42|   Validated 2067 Entries
2008/11/24 01:46:42|   store_swap_size = 19508k
2008/11/24 01:46:43| storeLateRelease: released 0 objects

this log youtube youtube_cache.log

2008-11-24 01:51:39,475 INFO 6ALWM046j6c CACHE_MISS YOUTUBE Requested video was not found in cache.
2008-11-24 01:51:39,478 INFO 6ALWM046j6c NEW_URL YOUTUBE
2008-11-24 01:51:40,383 INFO - REQUEST -
2008-11-24 01:51:40,971 INFO 6ALWM046j6c SCHEDULED YOUTUBE Video scheduled for download.
2008-11-24 01:51:41,074 INFO 6ALWM046j6c DOWNLOAD_ERR YOUTUBE An error occured while retrieving the video.

this log error or no cache?

by Anonymous on 1 Dec 2008

the same error is with me.. DOWNLOAD_ERR YOUTUBE and no cache. kindly help me out to resolve this matter

by Kulbir Saini on 1 Dec 2008


Please mention which version of videocache you are using? Nobody reported any problem with latest version 1.6 as of now which is available in download section. Try installing that. In case you still get errors, paste your /etc/videocache.conf file to .

Also, please mention your name instead of anonymous. It doesn't feel good to talk to anonymous :D

Thanks for using videocache :)